OpenSesame Plus user report CSV download system impaired
Incident Report for OpenSesame
Resolved
We have resolved the issue
Posted Apr 15, 2019 - 09:04 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 15, 2019 - 08:24 PDT
This incident affected: OpenSesame Catalog.