Server Update
Incident Report for OpenSesame
Resolved
Maintenance was completed successfully and all systems are operating normally.
Posted Mar 19, 2017 - 01:30 PDT
Monitoring
We are currently updating all systems and expect them to be restored by 19 March at 1:00am Pacific Time.
Posted Mar 18, 2017 - 20:38 PDT