Marketplace website is down

Incident Report for OpenSesame

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 15:30 PDT

Investigating

The Marketplace website is currently returning a 403 forbidden error. We are working to resolve this issue as quickly as possible.

Please reach out to our support team with any questions or concerns.
Posted Oct 15, 2025 - 15:07 PDT
This incident affected: OpenSesame Catalog.