OpenSesame home page is down. Please visit https://opensesame.com/home to log in to the Marketplace

Incident Report for OpenSesame

Resolved

We have resolved the issue. Thank you for your patience.

Please reach out to our support team with any questions or concerns.
Posted Oct 25, 2024 - 15:16 PDT

Investigating

We are investigating an issue with the OpenSesame home page. The Marketplace is up and fully operational. Please use https://www.opensesame.com/online-training-courses to log into the Marketplace.

We apologize for any inconvenience. Please reach out to our support team with any questions or concerns.
Posted Oct 25, 2024 - 12:15 PDT
This incident affected: OpenSesame Catalog.